Aloha Cloud Back Office 25.7.0 deployment to US production - Ongoing

Incident Report for NCR Voyix Status

Resolved

We have completed the Aloha Cloud Back Office deployment. We apologize for the inconvenience in this deployment.

regards,
NCR Voyix
Posted Jul 09, 2026 - 11:54 UTC

Identified

We are currently finalizing the Aloha Cloud back Office 25.7.0 deployment. We apologize for extending beyond the Maintenance window and are working to resolve this as quickly as possible
Posted Jul 09, 2026 - 10:50 UTC
This incident affected: Aloha Cloud (Aloha Cloud-NAMER).