ServiceNow Performance Issues

Incident Report for NCR Voyix Status

Resolved

Dear Valued Clients,

The ServiceNow vendor has confirmed that all services are operating as expected, and NCR Voyix internal teams have independently validated that ServiceNow functionality has been fully restored.
We are no longer observing any delays or performance degradation affecting case processing or integrations.

Based on the successful validation of service restoration and system stability, NCR Voyix will now proceed with resolving this incident.

We appreciate your patience and understanding throughout this event and thank you for your continued partnership.

Kind regards,
NCR Voyix Support Team
Posted Jul 18, 2026 - 12:09 UTC

Monitoring

Dear Valued Clients,

The ServiceNow vendor has completed the recovery activities and has transitioned NCR Voyix services back to the primary server environment. At this time, we are observing normal operation across all ServiceNow services, with no delays in case processing or integration workflows.

NCR Voyix teams will continue to closely monitor the environment to ensure ongoing system stability and verify that all services remain fully operational.

Our next update will be provided as additional information becomes available or within the next hour.

Thank you for your patience and understanding.

Kind regards,
NCR Voyix Support Team
Posted Jul 18, 2026 - 11:55 UTC

Update

Dear Valued Clients,

ServiceNow team has identified issues with one of their servers. ServiceNow team will perform fail over to backup server which will have impact to regular services including downtime of 5-15 minutes.
We will be providing regular updates as soon as they are available.

Thank You,
The NCR Voyix Team.
Posted Jul 18, 2026 - 11:05 UTC

Identified

Dear Valued Clients,

We are currently experiencing additional issues within the ServiceNow environment that are causing degraded system performance and may result in delays in case processing and related workflows.

The ServiceNow vendor has been engaged and is actively investigating the issue to determine the underlying cause and implement corrective actions. NCR Voyix teams are working closely with the vendor and are continuously monitoring the situation.
We understand the importance of our services to your daily operations and are committed to restoring full service stability as quickly as possible.

Further updates will be provided as additional information becomes available or within the next hour.
Thank you for your patience and understanding.

We’re on this,
The NCR Voyix Team
Posted Jul 18, 2026 - 10:31 UTC

Update

Dear Valued Clients,

We are currently experiencing additional issues within the ServiceNow environment that are causing degraded system performance and may result in delays in case processing and related workflows.

The ServiceNow vendor has been engaged and is actively investigating the issue to determine the underlying cause and implement corrective actions. NCR Voyix teams are working closely with the vendor and are continuously monitoring the situation.
We understand the importance of our services to your daily operations and are committed to restoring full service stability as quickly as possible.

Further updates will be provided as additional information becomes available or within the next hour.
Thank you for your patience and understanding.

We’re on this,
The NCR Voyix Team
Posted Jul 18, 2026 - 10:30 UTC

Monitoring

Dear Valued Clients,

The ServiceNow vendor has identified the root cause of the performance degradation and has implemented the necessary corrective actions.
At this time, we are observing normal system performance and stability, and customer case processing is operating as expected.

NCR Voyix teams continue to closely monitor the environment to ensure service stability is maintained and that no further issues are encountered.

We will remain engaged with the vendor and will continue to monitor the situation closely.
Further updates will be provided should additional information become available or within the next hour.

We’re on this,
Posted Jul 18, 2026 - 09:48 UTC

Update

Dear Valued Clients,

NCR Voyix is actively engaged with the ServiceNow vendor to investigate and address the performance degradation affecting the platform. Users may continue to experience intermittent slowness when accessing ServiceNow, including delays with page loads, ticket updates, and other system functions.

Our teams are working closely with the vendor to identify the underlying cause and implement corrective actions to restore normal service performance as quickly as possible. We appreciate your patience and understanding as we continue to work toward resolution.

Further updates will be provided as additional information becomes available or in an hour.

We’re on this,
The NCR Voyix Team
Posted Jul 18, 2026 - 09:04 UTC

Investigating

Dear Valued Clients,

We are currently investigating reports of degraded performance affecting the ServiceNow Integration. We are actively engaged in identifying the source of the performance degradation and working to restore normal responsiveness as quickly as possible.

We understand the importance of timely access to ServiceNow and are closely monitoring the situation.

We will provide additional updates as more information becomes available.

We’re on this,
The NCR Voyix Team
Posted Jul 18, 2026 - 08:32 UTC
This incident affected: Support Engagement Tools (ServiceNow Ticket Integration-NAMER, ServiceNow Ticket Integration-EMEA, ServiceNow Ticket Integration-APAC).