Thank you for your patience, services have been restored. Update on Service Disruption: We experienced a temporary issue affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Resolved: We have been experiencing intermittent service degradation with our processing technology partner in North America. Currently the system is currently processing.
Follow-Up: We're conducting a root cause analysis to ensure this doesn't recur. Details will be shared as they become available.
Thank You: We understand the critical role our services play in your operations and appreciate you as our customer. Thank you for your continued trust in NCR Voyix. Please contact us with any questions or concerns.
We’re in this together, The NCR Voyix Team
Posted Mar 05, 2025 - 19:36 EST
Monitoring
Dear Valued Clients,
Thank you for your patience, services have been restored. Update on Service Disruption: We experienced a temporary issue affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Resolved: We have been experiencing intermittent service degradation with our processing technology partner in North America. Currently the system is processing but we are continuing to monitor the situation closely.
Follow-Up: We're conducting a root cause analysis to ensure this doesn't recur. Details will be shared as they become available.
Thank You: We understand the critical role our services play in your operations and appreciate you as our customer. Thank you for your continued trust in NCR Voyix. Please contact us with any questions or concerns.
We’re in this together, The NCR Voyix Team
Posted Mar 05, 2025 - 19:01 EST
Update
Dear Valued Clients,
We have been experiencing intermittent service degradation with our processing technology partner in North America. Currently the system is processing but we are continuing to monitor the situation closely.
We will keep you informed as we have more information.
We sincerely apologize for the disruption to your operations.
NCR Voyix.
Posted Mar 05, 2025 - 18:49 EST
Update
Dear Valued Clients,
We have been experiencing intermittent service degradation with our processing technology partner.
Currently the system is processing but we are continuing to monitor the situation closely.
We will keep you informed as we have more information. We sincerely apologize for the disruption to your operations.
We’re on this, The NCR Voyix Team
Posted Mar 05, 2025 - 18:40 EST
Update
Dear Valued Clients, We understand services have been disrupted and we are finding a solution to the issue. Update on Service Disruption: We are experiencing a temporary issue affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Quick Action: Our Teams have found possible solution for the issue are working on stabilizing services.
Thank You: We understand the critical role our services play in your operations and appreciate your patience and understanding.
We’re on this, The NCR Voyix Team
Posted Mar 05, 2025 - 17:25 EST
Identified
Dear Valued Clients, We understand services have been disrupted and we are finding a solution to the issue. Update on Service Disruption: We are experiencing a temporary issue affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Quick Action: Our Teams have found possible solution for the issue are working on stabilizing services.
Thank You: We understand the critical role our services play in your operations and appreciate your patience and understanding.
We’re on this, The NCR Voyix Team
Posted Mar 05, 2025 - 17:13 EST
Update
Dear Valued Clients, We understand services have been disrupted and we are finding a solution to the issue. Update on Service Disruption: We are experiencing a temporary issue affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Quick Action: Our monitoring systems alerted us, and we are taking immediate action to restore services. We will communicate with you as quickly as possible, and details will be shared as they become available. Teams have reached to Google support for assistance with possible resolution.
Thank You: We understand the critical role our services play in your operations and appreciate your patience and understanding.
We’re on this, The NCR Voyix Team
Posted Mar 05, 2025 - 15:54 EST
Investigating
Dear Valued Clients, We understand services have been disrupted and we are finding a solution to the issue. Update on Service Disruption: We are experiencing a temporary issue affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Quick Action: Our monitoring systems alerted us, and we are taking immediate action to restore services. We will communicate with you as quickly as possible, and details will be shared as they become available.
Thank You: We understand the critical role our services play in your operations and appreciate your patience and understanding.
We’re on this, The NCR Voyix Team
Posted Mar 05, 2025 - 14:41 EST
This incident affected: Catalog-US, Order-US, TDM Count-US, and TDM Export-US.