Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 10, 2026 - 05:00 UTC
Scheduled
Scheduled Maintenance Notification Date: January 10, 2026 Time: 12:00 AM – 6:00 AM ET
NCR Voyix will be performing our annual Disaster Recovery Testing during the maintenance window above. This testing is a critical part of our compliance with SOX regulations and ensures the highest standards of application availability and resilience.
While we do not anticipate any downtime, NCR Voyix has proactively communicated with clients who may experience potential impact during this period.
Your satisfaction and trust remain our top priorities. These proactive measures reflect our ongoing commitment to delivering secure, reliable, and uninterrupted services. We appreciate your understanding and partnership as we strengthen our systems for your benefit.
If you have any questions or concerns, please contact our support team.
Thank you for your continued confidence in NCR Voyix.
Posted Jan 05, 2026 - 14:35 UTC
This scheduled maintenance affected: Support Engagement Tools (ServiceNow Ticket Integration-NAMER, ServiceNow Ticket Integration-EMEA, ServiceNow Ticket Integration-APAC).