Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 04, 2026 - 21:06 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 04, 2026 - 17:30 UTC
Scheduled
Dear Valued Customer,
On 4th March, 2026, between 17:30 UTC and 21:30 UTC during the scheduled maintenance window, NCR Voyix will patch and reboot servers and will rebuilt one of the web-order server. During this activity, you may experience interruption with connecting client and console.
At NCR Voyix, your satisfaction and trust are our top priorities. These proactive measures are part of our ongoing commitment to deliver secure, reliable, and uninterrupted services. We appreciate your understanding and partnership as we work to strengthen our systems for your benefit . If you have any questions or concerns, please do not hesitate to reach out to our support team. Thank you for your continued confidence in NCR Voyix.