Service Degradation Notice: ServiceNow Performance Issues

Incident Report for NCR Voyix Status

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 18:18 UTC

Identified

NCR Voyix is actively engaged with the ServiceNow vendor to investigate and address the performance degradation affecting the platform. Users may continue to experience intermittent slowness when accessing ServiceNow, including delays with page loads, ticket updates, and other system functions.

Our teams are working closely with the vendor to identify the underlying cause and implement corrective actions to restore normal service performance as quickly as possible. We appreciate your patience and understanding as we continue to work toward resolution.

Further updates will be provided as additional information becomes available or in an hour.
Posted Jul 16, 2026 - 17:09 UTC

Update

NCR Voyix support teams are continuing to address the issue.

Updates to follow upon significant progress or in one hour.
Posted Jul 16, 2026 - 16:19 UTC

Investigating

We are currently investigating reports of degraded performance affecting the ServiceNow Integration. We are actively engaged in identifying the source of the performance degradation and working to restore normal responsiveness as quickly as possible.

We understand the importance of timely access to ServiceNow and are closely monitoring the situation.

We will provide additional updates as more information becomes available.

Thank you for your patience and understanding as we work to resolve this issue.

NCR Voyix
Posted Jul 16, 2026 - 15:23 UTC
This incident affected: Support Engagement Tools (ServiceNow Ticket Integration-NAMER).