Thank you for your patience, services have been restored.
Update on Service Disruption: We are experiencing a temporary issue with our Cloud provider affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Resolved: Issue is resolved, but we are still monitoring. Our Cloud provider have applied fix on their side, and we are seeing activity on all services In our monitoring tools.
Follow-Up: Root cause analysis will be performed by our Cloud partner. Details will be shared as they become available.
Thank You: We understand the critical role our services play in your operations and appreciate you as our customer. Thank you for your continued trust in NCR Voyix. Please contact us with any questions or concerns.
We’re in this together, The NCR Voyix Team
Posted Jun 12, 2025 - 17:29 EDT
Update
Dear Valued Clients,
Thank you for your patience, services have been restored.
Update on Service Disruption: We are experiencing a temporary issue with our Cloud provider affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Resolved: Issue is resolved, but we are still monitoring. Our Cloud provider have applied fix on their side, and we are seeing activity on all services In our monitoring tools.
Follow-Up: Root cause analysis will be performed by our Cloud partner. Details will be shared as they become available.
Thank You: We understand the critical role our services play in your operations and appreciate you as our customer. Thank you for your continued trust in NCR Voyix. Please contact us with any questions or concerns.
We’re in this together, The NCR Voyix Team
Posted Jun 12, 2025 - 16:51 EDT
Update
Dear Valued Clients,
We understand you are experiencing issues with the services.
Update on Service Disruption: We are experiencing a temporary issue with our Cloud Provider affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Quick Action: Our monitoring systems alerted us, and our teams are working with Cloud Provider on immediate action to restore services. We will communicate with you as quickly as possible, and details will be shared as they become available.
Thank You: We understand the critical role our services play in your operations and appreciate your patience and understanding.
We’re on this, The NCR Voyix Team
Posted Jun 12, 2025 - 15:59 EDT
Investigating
Dear Valued Clients,
We understand services have been disrupted and we are finding a solution to the issue.
Update on Service Disruption: We are experiencing a temporary issue with our Cloud Provider affecting NCR Voyix BSL services, including Catalog, CDM, and TDM.
Quick Action: Our monitoring systems alerted us, and our teams are working with Cloud Provider on immediate action to restore services. We will communicate with you as quickly as possible, and details will be shared as they become available.
Thank You: We understand the critical role our services play in your operations and appreciate your patience and understanding.
We’re on this, The NCR Voyix Team
Posted Jun 12, 2025 - 14:56 EDT
This incident affected: Consumer Data Management-US, Consumer Data Management-EMEA, Consumer Data Management-APAC, Consumer Data Management-NAPAC, Order-US, Order-EMEA, Order-APAC, Transaction Document Management-US, Transaction Document Management-EMEA, and Transaction Document Management-APAC.