Degradation of Service - NAMER

Incident Report for NCR Voyix

Resolved

NCRV has implemented the mitigation change during the regular maintenance window. All systems re healthy and actively being monitored.

Please contact NCRV Support should you have any problems
Posted Aug 18, 2025 - 06:29 EDT

Monitoring

At approximately 10:00am EDT, NCR Voyix encountered a degradation in service for all North America customers. We apologize for this inconvenience and have resolved the issue at 12:00pm EDT. We are still working to do a full RCA of the cause. Monitoring has been added to alert us if a potential issue was to arise again and a mitigating change will be put into place during our standard maintenance window this evening.
Posted Aug 17, 2025 - 15:59 EDT
This incident affected: BSP - Other.