NCR Voyix Status logo

Action Required: Update Portal Access to Secure HTTPS URL Before September 22

Scheduled for Sep 22, 04:00 - 05:00 UTC

Scheduled

To enhance security and align with current compliance standards, Voyix Connect is retiring legacy HTTP access and requiring secure HTTPS connections for all portal access.

What Is Changing
• Effective September 22, access through the following URL will no longer be available: http://www.servereps.com
• The secure HTTPS URL will remain unchanged and fully supported: https://www.servereps.com
• All portal functionality and services will continue to operate normally.

Recommended actions:
• Update browser bookmarks and favorites
• Update internal documentation and training materials
• Review scripts, monitoring tools, and automated processes
• Verify all portal references use the HTTPS URL

If you have questions or need support updating your environment, please contact the Voyix Connect Support team at voyixconnect.support@ncrvoyix.com
Posted Sep 08, 2026 - 17:27 UTC
This scheduled maintenance affects: Voyix Connect (Voyix Connect Gateway - Retail-NAMER).