NCR Voyix Digital Ordering and Online Ordering Classic services degraded for Namer region

Incident Report for NCR Voyix Status

Resolved

Dear Valued Clients,


Our teams responded promptly to the issue affecting the NCR Voyix Digital Ordering and Online Ordering Classic services and have implemented the necessary corrective actions.

Thank You: We understand the critical role our services play in your operations and appreciate you as our customer. Thank you for your continued trust in NCR Voyix. Please contact us with any questions or concerns.

We’re in this together,
The NCR Voyix Team
Posted Feb 24, 2026 - 12:52 UTC

Update

Dear Valued Clients,


Our teams responded promptly to the issue affecting the NCR Voyix Digital Ordering and Online Ordering Classic services and have implemented the necessary corrective actions.

Thank You: We understand the critical role our services play in your operations and appreciate you as our customer. Thank you for your continued trust in NCR Voyix. Please contact us with any questions or concerns.

We’re in this together,
The NCR Voyix Team
Posted Feb 24, 2026 - 12:07 UTC

Investigating

Dear Valued Clients,

We are experiencing a temporary post maintenance issue affecting NCR Voyix Digital Ordering and Online Ordering Classic services.

Our monitoring systems alerted us that the system is degraded and not operating at 100%. We are taking immediate action to restore services to their full capacity. We will communicate with you as quickly as possible, and details will be shared as they become available.

Thank You: We understand the critical role our services play in your operations and appreciate your patience and understanding.
Posted Feb 24, 2026 - 11:40 UTC
This incident affected: Restaurant Engage (Digital Ordering-NAMER, Online Ordering Classic-NAMER).