NCR Voyix Status logo

Investigating | Aloha Cloud: Degraded Performance with Printing for a Subset of Customers

Incident Report for NCR Voyix Status

Resolved

Service has been restored, and the issue affecting Aloha Cloud Printing has been resolved. We will continue to monitor.

If you continue to experience an issue, please contact NCR Voyix Support or your Account Executive.
Posted Sep 14, 2026 - 23:55 UTC

Investigating

We are investigating a service issue affecting Aloha Cloud. Customers may experience Printing degradation.

Our teams are actively working to identify the cause and restore any affected services.

We will provide the next update by 20:00 ET, or sooner if additional information becomes available.
Posted Sep 14, 2026 - 23:09 UTC
This incident affected: Aloha Cloud (Aloha Cloud-NAMER).