Secure Pay - Subset of Customers - Unable to Process

Incident Report for NCR Voyix Status

Resolved

The previously reported issue impacting Secure Pay for a subset of customers has been resolved, and services are now operating normally.

NCR Voyix is grateful for your patience and understanding while our teams worked to restore and improve service reliability. We recognize the importance of Secure Pay to your operations and remain committed to maintaining a stable and reliable service.

Regards,
The NCR Voyix Team
Posted Apr 14, 2026 - 17:30 UTC

Identified

NCR Voyix will be implementing a planned change on April 14, 2026, at 06:00 UTC to address the ongoing Secure Pay issue. The maintenance activity is expected to last approximately one (1) hour.

During this maintenance window, customers may experience temporary interruptions of service.

We recognize the importance of service reliability to your operations and appreciate your patience as we work toward resolution and improved system stability.

Additional updates will be provided upon completion of the change.

Regards,
The NCR Voyix Team
Posted Apr 13, 2026 - 15:20 UTC

Update

NCR Voyix will be implementing a change at 06:00 UTC on April 6, 2026, to help mitigate this issue.

Thank you for your patience in this matter.

Regards,
NCR Voyix
Posted Apr 03, 2026 - 21:57 UTC

Update

NCR Voyix support Teams are continuing to investigate this issue.

We understand the critical role our services play in your operations and appreciate your patience and understanding.

We’re on this,
The NCR Voyix Team
Posted Mar 27, 2026 - 22:13 UTC

Update

NCR Voyix support Teams are continuing to investigate this issue.

We understand the critical role our services play in your operations and appreciate your patience and understanding.

We’re on this,
The NCR Voyix Team
Posted Mar 26, 2026 - 19:26 UTC

Update

We are continuing to investigate this issue.
Posted Mar 26, 2026 - 14:23 UTC

Investigating

Dear Valued Clients,

We have identified an issue regarding Secure Pay for a subset of customers for components listed below. We are taking the necessary steps to resolve the issue.

We understand the critical role our services play in your operations and appreciate your patience and understanding.

We’re on this,
The NCR Voyix Team
Posted Mar 26, 2026 - 13:47 UTC
This incident affected: Secure Pay (Secure Pay-NAMER).