Transaction Data Management - Investigating Issues

Incident Report for NCR Voyix

Resolved

We are currently experiencing issues for the following component(s) and are looking into them.
Posted Mar 05, 2025 - 18:20 EST

Investigating

We are currently experiencing issues for the following component(s) and are looking into them.
Posted Mar 05, 2025 - 14:22 EST
This incident affected: Transaction Document Management-US.